おすすめのガジェット

「Local’s router is having trouble starting」でページが開けない

「Local's router is having trouble starting」でページが開けない

ローカル環境にWordPressのテスト環境をかんたんに構築できる「Local by Flywheel」を使って開発をしています。

今まではバージョン3系を使用していたのですが、5系は速度が改善されたと聞いて試してみました。

 

インストールしてサイトを新規作成してみたところ、上部に赤帯でメッセージが表示されてサイトにアクセスできませんでした。

Heads-up! Local’s router is having trouble starting.

上部に赤帯でメッセージが表示されてサイトにアクセスできませんでした。

 

指定したサイトドメインでアクセスできるようにはできなかったので、暫定的な対応ですが使うことができるようにはなりました。

同じバージョンのLocalをサブPCで試したら普通にサイトドメインを使用できたので、もしかしたら3系のLocalが原因かもしれません。

 

スポンサーリンク

作成したドメインにアクセスできない

「502」エラーとメッセージが表示されて、エラーになっていました。

「502」エラーとメッセージが表示されて、エラーになっていました。

メッセージの内容的には「サーバーエラーで表示できない。再起動してもだめならLocalのルーターログを見てね。」とのこと。

The page you requested generated a server error and could not be processed.
If you continue to get this message after refreshing, try restarting the Local site.

If the error persists, check the Local Router Logs in Local by going to
Help » Reveal Local Router's Logs.

 

「このサイトにアクセスできません」「xxxxx で接続が拒否されました。」とも表示されました。

「このサイトにアクセスできません」「xxxxx で接続が拒否されました。」とも表示されました。

 

スポンサーリンク

解決方法

ベストな解決結果ではないと思いますが、とりあえずサイトを表示することができました。

Localの左上のメニューボタンから「Preferences」をクリックします。

「Preferences」をクリックします。

 

左の「ADVANCED」を選択し、Router Modeを「localhost」モードを選びます。

Router Modeを「localhost」モードを選びます。

 

「localhost」を選択したら右下の「APPLY」ボタンを押して反映します。

右下の「APPLY」ボタンを押して反映します。

 

もう一度サイトを起動させて「ADMIN」ボタンでWordPressの管理画面開きます。

Site Hostは「localhost:0000」に変わっています。

「ADMIN」ボタンでWordPressの管理画面開きます。

 

サイトメインはlocalhostとポート番号の形式に変わってしまいましたが、一応WordPressサイトが作成できました。

一応WordPressサイトが作成できました。

 

スポンサーリンク

根本原因はベータ版だから?環境のせい?

サブPCは同じLocalのバージョンで、同じ設定でWordPress環境を構築したところ正常に使うことができました。

ちなみにサブPCのSSLのOpenSSL VersionでPHP Warningが出ているのは同じだったので、これはあまり関係ないっぽい。

SSLのOpenSSL VersionでPHP Warningが出ている

 

Warning: PHP Startup: Unable to load dynamic library 'php_imagick.dll'
 (tried: C:/Users/xxxx/AppData/Roaming/Local/lightning-services/php-7.4.1+5/bin/win32/ext\php_imagick.dll (指定されたモジュールが見つかりません。), 
 C:/Users/xxxx/AppData/Roaming/Local/lightning-services/php-7.4.1+5/bin/win32/ext\php_php_imagick.dll.dll (指定されたモジュールが見つかりません。))
 in Unknown on line 01.1.1d  10 Sep 2019

 

メインPCは3系のLocalだけでなく、色んな開発で使っているので何かが影響しているんだろうなと感じました。

 

それでも駄目なら3系でガマン

公式のヘルプでもサイトドメインがダメならlocalhostモードを使えとしか記載が無いので、localhostとポート番号がテスト環境として不便かもしれません。

早く安定した5系をリリースしてほしいものです。

 

 

コメント

目次へ
タイトルとURLをコピーしました